Retroactive Incident Update: Personalized Emails

Informational
March 10, 4:02pm

Retroactive Incident Update: Personalized Emails

Status: closed
Date: March 10, 6:13am
End: March 10, 4:02pm
Duration: 9 hours 49 minutes
Affected Components:
Email Messaging
Update

March 10, 6:13am

March 10, 6:13am

Between 2026-03-10 06:13:36 AM PST and 2026-03-10 4:02:31 PM PST, the personalized emails experienced partial failure. During that time, approximately 20% of email messages were not delivered. This issue potentially impacted all email customers. 

Our engineering team has implemented a fix, and this issue has been resolved. 

Please feel free to contact Airship Technical Support at https://support.airship.com, if you have any questions or concerns.

Resolved

March 10, 4:02pm

March 10, 4:02pm

This issue has been resolved.

Please feel free to contact Airship Technical Support at https://support.airship.com, if you have any questions or concerns.